package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<span>.*?</span>(*SKIP)(*FAIL)
|
(?:
(?:\G(?!\A)|\[)
[^\d\]]*
(\d+)
[^\d\]]*
\K
)`)
var str = `strings123[abc123<span>123</span>def<span>456</span>123]strings456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}