package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<\n]*[\)\]`])[^()\n]*)big`)
var str = `Should Match:
I like \`xx\` big \`xx\` cakes
I like big cakes
I like \`big cakes
I like big\` cakes
I like xx big xx cakes
I like \` xx big xx cakes
I like xx big xx\` cakes
I like \`xx\` big \`xx\` cakes
I like big cakes
I like ]big cakes
I like big] cakes
I like xx big xx cakes
I like ] xx big xx cakes
I like xx big xx] cakes
I like ]xx] big ]xx] cakes
I like big cakes
I like (big cakes
I like big) cakes
I like xx big xx cakes
I like ( xx big xx cakes
I like xx big xx) cakes
I like (xx) big (xx) cakes
Should not Match:
I like (big) cakes
I like (xx big xx) cakes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}