re = /\s(<.+)/m
str = '<span id="3">
HELLO THERE
<span id="5">
Other stuff
<span id="6">
Other Stuff
<span id="7">
Other sutff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end