import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((&&|<=|>=|<|>|!=|==|&|!)|([-+=]{1,2})|([.!?)\\}\\{;,(-]))|(else|if|float|int)|(\\d[\\d.]))";
final String string = "int a, b, c;\n"
+ "float d, e;\n"
+ "a = b = 5;\n"
+ "c = 6;\n"
+ "if ( a > b)\n"
+ "{\n"
+ "c = a - b;\n"
+ "e = d - 2.0;\n"
+ "}\n"
+ "else\n"
+ "{\n"
+ "d = e + 6.0;\n"
+ "b = a + c;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}