# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[\(\d\s\)-]{8,}\b|(\d\s?){8,12}\b//g;t' <<< "0944 888 890/ 0903 126 233 | phon0944 888 890/ 0903888 890/ 0903 126 233 | phon0944 888 890/ 84 0903 126 233 | phongnguyen@huuphongplastic.vn/ thaongo@huuphongplastic.vn"