$re = '/^\s*(.*?)\s*$/m';
$str = '
test string
hello world. ';
$subst = "\1, ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;