using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(?P<IgnoreBracket>\(?)(?P<area_code>\d{3}?|\d{3})(?P<IgnoreBracket2>\s|\)?)(?P<IgnoreSpecChar>\s*?|-?)(?P<first_three>\d{3})(?P<IgnoreSpecChar1>-?)(?P<last_four>\d{4})\s*?";
string input = @"(404-555-1212
^(?P<IgnoreBracket>\(?)(?P<area_code>\d{3}?|\d{3})(?P<IgnoreBracket2>\)?)(\s*?|-?)(?P<first_three>\d{3})-?(?P<last_four>\d{4})\s*?
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}