re = /^\s*(?P<IgnoreBracket>\(?)(?P<area_code>\d{3}?|\d{3})(?P<IgnoreBracket2>\s|\)?)(?P<IgnoreSpecChar>\s*?|-?)(?P<first_three>\d{3})(?P<IgnoreSpecChar1>-?)(?P<last_four>\d{4})\s*?/m
str = '(404-555-1212
^(?P<IgnoreBracket>\\(?)(?P<area_code>\\d{3}?|\\d{3})(?P<IgnoreBracket2>\\)?)(\\s*?|-?)(?P<first_three>\\d{3})-?(?P<last_four>\\d{4})\\s*?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end