// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(?P<IgnoreBracket>\(?)(?P<area_code>\d{3}?|\d{3})(?P<IgnoreBracket2>\s|\)?)(?P<IgnoreSpecChar>\s*?|-?)(?P<first_three>\d{3})(?P<IgnoreSpecChar1>-?)(?P<last_four>\d{4})\s*?").unwrap();
let string = "(404-555-1212
^(?P<IgnoreBracket>\\(?)(?P<area_code>\\d{3}?|\\d{3})(?P<IgnoreBracket2>\\)?)(\\s*?|-?)(?P<first_three>\\d{3})-?(?P<last_four>\\d{4})\\s*?
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}