import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(\\S+)$";
final String string = "Austria: ac.at\n"
+ "Bangladesh: ac.bd\n"
+ "Belgium: ac.be\n"
+ "China: ac.cn\n"
+ "Cyprus: ac.cy\n"
+ "India: ac.in";
final String subst = "$Resolved URL$ LIKE \"*$1/*\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}