$re = '/^([A-Z0-9]{16})$/m';
$str = 'Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);