// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Z0-9]{16})$").unwrap();
let string = "Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}