const regex = /Diagnosis Statement:\s*.*\s*\K^([A-Z0-9]{16})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Diagnosis Statement:\\s*.*\\s*\\K^([A-Z0-9]{16})$', 'gm')
const str = `Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report
Diagnosis Statement:
6/28/2011
RZZZCG77T77G355S
Report text is here ....... end of report
This must not match because there is not the magic words before!
RZZZCG77T77G355S
This must match, even if there is no date between the magic words and the thing to match :
Diagnosis Statement:
RZZZCG77T77G355S
Report text is here ....... end of report`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}