use strict;
my $str = '+word1 -word2 -"word word"';
my $regex = qr/"[^"]+"(*SKIP)(*FAIL)|\h+/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";