re = /"[^"]+"(*SKIP)(*FAIL)|\h+/m
str = '+word1 -word2 -"word word"'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result