// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[^"]+"(*SKIP)(*FAIL)|\h+"#).unwrap();
let string = "+word1 -word2 -\"word word\"";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}