$re = '/(\s\*)([^*]+)(\*\s)/';
$str = 'test string *67* **Hi**';
$subst = "$1hello$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;