Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?!(^$|[-]{1}[.]{1}|[0]{1}[0-9]+|[-]{1}[0]{1}[0-9]+))([\-]{0,1}[1-9]?[0-9]*((\.|\,)[0-9]*)?|[0]((\.|\,)[0-9]*)?)$
/
g
Input 1
1
New
-0.123122342765172635778687