// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(\\[\s\S]|[^"])*"|'(\\[\s\S]|[^'])*'|(\/\/.*|\/\*[\s\S]*?\*\/)"#).unwrap();
let string = "QUOTES
str = '//\\''; // comment.'test'
str = \"//'\"; // comment.
str = '\\'//\\''; // comment.
str = '\"\\'//\\'\"'; // comment.
str = \"'// \"; // comment.
COMMENTS
/*'//\\'';// hjkjh.'test'
\"//'\";// hjkjh.
'\\'//\\'';// hjkjh.
\"'// \";// hjkjh.*/ yo; // test.
// var i = 'able';";
let substitution = "[$1], [$2], [$3]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}