#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""((?:\\"|[^"])*)"|'((?:\\'|[^'])*)'|(\/\/.*|\/\*[\s\S]*?\*\/)"
Local $sString = "QUOTES" & @CRLF & _
"str = '//\''; // comment.'test'" & @CRLF & _
"str = "//'"; // comment." & @CRLF & _
"str = '\'//\''; // comment." & @CRLF & _
"str = '"\'//\'"'; // comment." & @CRLF & _
"str = "'// "; // comment." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"COMMENTS" & @CRLF & _
"/*'//\'';// hjkjh.'test'" & @CRLF & _
""//'";// hjkjh." & @CRLF & _
"'\'//\'';// hjkjh." & @CRLF & _
""'// ";// hjkjh.*/ yo; // test." & @CRLF & _
"" & @CRLF & _
"// var i = 'able';"
Local $sSubst = "[$1], [$2], [$3]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)