using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""((?:\\""|[^""])*)""|'((?:\\'|[^'])*)'|(\/\/.*|\/\*[\s\S]*?\*\/)";
string substitution = @"[$1], [$2], [$3]";
string input = @"QUOTES
str = '//\''; // comment.'test'
str = ""//'""; // comment.
str = '\'//\''; // comment.
str = '""\'//\'""'; // comment.
str = ""'// ""; // comment.
COMMENTS
/*'//\'';// hjkjh.'test'
""//'"";// hjkjh.
'\'//\'';// hjkjh.
""'// "";// hjkjh.*/ yo; // test.
// var i = 'able';";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}