package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"((?:\\"|[^"])*)"|'((?:\\'|[^'])*)'|(\/\/.*|\/\*[\s\S]*?\*\/)`)
var str = `QUOTES
str = '//\''; // comment.'test'
str = "//'"; // comment.
str = '\'//\''; // comment.
str = '"\'//\'"'; // comment.
str = "'// "; // comment.
COMMENTS
/*'//\'';// hjkjh.'test'
"//'";// hjkjh.
'\'//\'';// hjkjh.
"'// ";// hjkjh.*/ yo; // test.
// var i = 'able';`
var substitution = "[$1], [$2], [$3]"
fmt.Println(re.ReplaceAllString(str, substitution))
}