use strict;
my $str = 'QUOTES
str = \'//\\\'\'; // comment.\'test\'
str = "//\'"; // comment.
str = \'\\\'//\\\'\'; // comment.
str = \'"\\\'//\\\'"\'; // comment.
str = "\'// "; // comment.
COMMENTS
/*\'//\\\'\';// hjkjh.\'test\'
"//\'";// hjkjh.
\'\\\'//\\\'\';// hjkjh.
"\'// ";// hjkjh.*/ yo; // test.
// var i = \'able\';';
my $regex = qr/"((?:\\"|[^"])*)"|'((?:\\'|[^'])*)'|(\/\/.*|\/\*[\s\S]*?\*\/)/p;
my $subst = '[$1], [$2], [$3]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";