import Foundation
let pattern = #""((?:\\"|[^"])*)"|'((?:\\'|[^'])*)'|(\/\/.*|\/\*[\s\S]*?\*\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
QUOTES
str = '//\''; // comment.'test'
str = "//'"; // comment.
str = '\'//\''; // comment.
str = '"\'//\'"'; // comment.
str = "'// "; // comment.
COMMENTS
/*'//\'';// hjkjh.'test'
"//'";// hjkjh.
'\'//\'';// hjkjh.
"'// ";// hjkjh.*/ yo; // test.
// var i = 'able';
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1], [$2], [$3]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)