// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<br>\s?-\s?(.*?)").unwrap();
let string = "any text - any text any text any text any text any text
<br><br>- any text any text<br>- any text 1 2 3 | \\ ,<br><br>
<br>any text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}