import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:.*\\(.*)(\\+|-{1})(?: )(\\d+\\.*?\\d+)(?:.*\\))";
final String string = "option 1 ( + 10.2$ )\n"
+ "option 2 ( - 110.00$ )\n"
+ "option 2 ( - 110$ )\n"
+ "option 2 ( + 0.1$ )\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}