const regex = new RegExp('(?:.*\\(.*)(\\+|-{1})(?: )(\\d+\\.*?\\d+)(?:.*\\))', 'gi')
const str = `option 1 ( + 10.2\$ )
option 2 ( - 110.00\$ )
option 2 ( - 110\$ )
option 2 ( + 0.1\$ )
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);