$re = '/(?:.*\(.*)(\+|-{1})(?: )(\d+\.*?\d+)(?:.*\))/i';
$str = 'option 1 ( + 10.2$ )
option 2 ( - 110.00$ )
option 2 ( - 110$ )
option 2 ( + 0.1$ )
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;