# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:https?://)?(?:www\.)?\S+\.\S+$"
test_str = ("www.website1.com\n"
"www.website2.com\n"
"www.website3.nl\n"
"www.website3.nl !\n"
"www.website3.nl !\n"
"www.website3.nl !\n"
"www.website1.com\n"
"websit.ea.pl\n"
"websit.ea.pl\n"
"websit.ea.pl\n"
"http://www.website2.com\n"
"https://www.website2.com\n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.