package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)def+`)
var str = `de def deff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}