$re = '/\bdef{3,4}\b/m';
$str = 'de def defff deffff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);