package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{12}(?:00[1-9]|0[1-9]\d|[1-9]\d\d)$`)
var str = `123412341234001`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}