const regex = /\d{12}(?:00[1-9]|0[1-9]\d|[1-9]\d\d)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{12}(?:00[1-9]|0[1-9]\\d|[1-9]\\d\\d)$', '')
const str = `123412341234001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}