using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#\w+|[^#\s][^\s#]*(?:\s+[^#\s][^\s#]*)*";
string input = @"привет #username text text #username2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}