#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$"
Local $sString = "R3KEE" & @CRLF & _
"UA3QUP" & @CRLF & _
"RK3DSW" & @CRLF & _
"U4AI" & @CRLF & _
"RU3OZ" & @CRLF & _
"RA3QH" & @CRLF & _
"RU4I" & @CRLF & _
"RL3K" & @CRLF & _
"UA3QBQ" & @CRLF & _
"UR5EQF" & @CRLF & _
"D1IJZ" & @CRLF & _
"US3IW" & @CRLF & _
"IU3QEU" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")