import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$";
final String string = "R3KEE\n"
+ "UA3QUP\n"
+ "RK3DSW\n"
+ "U4AI\n"
+ "RU3OZ\n"
+ "RA3QH\n"
+ "RU4I\n"
+ "RL3K\n"
+ "UA3QBQ\n"
+ "UR5EQF\n"
+ "D1IJZ\n"
+ "US3IW\n"
+ "IU3QEU\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}