const regex = /^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$', 'gm')
const str = `R3KEE
UA3QUP
RK3DSW
U4AI
RU3OZ
RA3QH
RU4I
RL3K
UA3QBQ
UR5EQF
D1IJZ
US3IW
IU3QEU
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}