use strict;
my $str = 'R3KEE
UA3QUP
RK3DSW
U4AI
RU3OZ
RA3QH
RU4I
RL3K
UA3QBQ
UR5EQF
D1IJZ
US3IW
IU3QEU
';
my $regex = qr/^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}