# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$"
test_str = ("R3KEE\n"
"UA3QUP\n"
"RK3DSW\n"
"U4AI\n"
"RU3OZ\n"
"RA3QH\n"
"RU4I\n"
"RL3K\n"
"UA3QBQ\n"
"UR5EQF\n"
"D1IJZ\n"
"US3IW\n"
"IU3QEU\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.