re = /^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$/m
str = 'R3KEE
UA3QUP
RK3DSW
U4AI
RU3OZ
RA3QH
RU4I
RL3K
UA3QBQ
UR5EQF
D1IJZ
US3IW
IU3QEU
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end