// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$").unwrap();
let string = "R3KEE
UA3QUP
RK3DSW
U4AI
RU3OZ
RA3QH
RU4I
RL3K
UA3QBQ
UR5EQF
D1IJZ
US3IW
IU3QEU
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}