$re = '/^((?P<all>apple|bat|car)), (?!\1)((?P>all)), (?!\1|\2)((?P>all))$/mi';
$str = 'apple, bat, car
apple, car, bat
bat, apple, car
car, bat, apple
FAILS
apple, bat, car, d
d, apple, bat, car
apple, bat, d, car
apple, apple, car
apple, apple, apple';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);