#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.* out: Built|published ).*$"
Local $sString = "Console ouput" & @CRLF & _
"published xyz" & @CRLF & _
"[servername] out: Built 123abcwxyabjd" & @CRLF & _
"few lines of o/p" & @CRLF & _
"[servername2] out: Built ewrewfdsfabcwxyabjd" & @CRLF & _
"again some o/p" & @CRLF & _
"[servername3] out: Built 1458543abcwxyabjd" & @CRLF & _
"published abc" & @CRLF & _
"some o/p" & @CRLF & _
"[servername2] out: Built dfds123abcwxyabjd" & @CRLF & _
"some o/p" & @CRLF & _
"[servername] out: Built dsfdsabcwxyabjd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")