$re = '/(?i)\b[p]*(ost)*\.*\s*[o]*(ffice)*\.*(?<=po|p.o|o\.|office|post)\s*[b][o][x]\b|(?<=\d\s|^)\s*[[b][o][x]]*(?!\s*[a-z])|(?<=\d\s|^)\s*[[p][o]]*(?!\s*[a-z])/m';
$str = '123 BOX STREET';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);