$re = '/\A(?:[^\|]+\|){2}\K(?P<foo>[^\|]*)/';
$str = '2017-05-13|23:59:59|127.0.0.1|8080|ReGeX|http://www.example.com/index.htm|!"£$%^&*()_+|qwerty';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);