re = /^(\+98|0|0098)?9\d{9}$/m
str = '09121234567
00989121234567
+989121234567
9121234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end