$re = '/\w+(?: \w+)*({(?:[^{}]++|(?1))*})/m';
$str = 'void function{ { { } }}
static stTLookupTable RxTable[MAX]={
{zero, one},{zero, one},{zero, one}};';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);