#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)<span>(?:[^<]|<(?!span>|\/span>))*<\/span>"
Local $sString = "Начало." & @CRLF & _
"<spar>ошибка</spar>" & @CRLF & _
"<span><b>правильно</b></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>правильно <i><span>правильно</span></i> правильно</span>." & @CRLF & _
"ошибка" & @CRLF & _
"<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>." & @CRLF & _
"ошибка" & @CRLF & _
"<span><spar>правильно</spar></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span><span></span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>ошибка<span>ошибка<span>правильно</span>" & @CRLF & _
"<span>ошибка<span>" & @CRLF & _
"Конец." & @CRLF & _
"" & @CRLF & _
"Начало." & @CRLF & _
"<spar>ошибка</spar>" & @CRLF & _
"<span><b>правильно</b></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>правильно <i><span>правильно</span></i> правильно</span>." & @CRLF & _
"ошибка" & @CRLF & _
"<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>." & @CRLF & _
"ошибка" & @CRLF & _
"<span><spar>правильно</spar></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span><span></span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>ошибка<span>ошибка<span>правильно</span>" & @CRLF & _
"<span>ошибка<span>" & @CRLF & _
"Конец." & @CRLF & _
"" & @CRLF & _
"Начало." & @CRLF & _
"<spar>ошибка</spar>" & @CRLF & _
"<span><b>правильно</b></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>правильно <i><span>правильно</span></i> правильно</span>." & @CRLF & _
"ошибка" & @CRLF & _
"<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>." & @CRLF & _
"ошибка" & @CRLF & _
"<span><spar>правильно</spar></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span><span></span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>ошибка<span>ошибка<span>правильно</span>" & @CRLF & _
"<span>ошибка<span>" & @CRLF & _
"Конец." & @CRLF & _
"" & @CRLF & _
"Начало." & @CRLF & _
"<spar>ошибка</spar>" & @CRLF & _
"<span><b>правильно</b></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>правильно <i><span>правильно</span></i> правильно</span>." & @CRLF & _
"ошибка" & @CRLF & _
"<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>." & @CRLF & _
"ошибка" & @CRLF & _
"<span><spar>правильно</spar></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span><span></span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>ошибка<span>ошибка<span>правильно</span>" & @CRLF & _
"<span>ошибка<span>" & @CRLF & _
"Конец." & @CRLF & _
"" & @CRLF & _
"Начало." & @CRLF & _
"<spar>ошибка</spar>" & @CRLF & _
"<span><b>правильно</b></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>правильно <i><span>правильно</span></i> правильно</span>." & @CRLF & _
"ошибка" & @CRLF & _
"<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>." & @CRLF & _
"ошибка" & @CRLF & _
"<span><spar>правильно</spar></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span><span></span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>ошибка<span>ошибка<span>правильно</span>" & @CRLF & _
"<span>ошибка<span>" & @CRLF & _
"Конец." & @CRLF & _
"" & @CRLF & _
"Начало." & @CRLF & _
"<spar>ошибка</spar>" & @CRLF & _
"<span><b>правильно</b></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>правильно <i><span>правильно</span></i> правильно</span>." & @CRLF & _
"ошибка" & @CRLF & _
"<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>." & @CRLF & _
"ошибка" & @CRLF & _
"<span><spar>правильно</spar></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span><span></span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>ошибка<span>ошибка<span>правильно</span>" & @CRLF & _
"<span>ошибка<span>" & @CRLF & _
"Конец." & @CRLF & _
"" & @CRLF & _
"Начало." & @CRLF & _
"<spar>ошибка</spar>" & @CRLF & _
"<span><b>правильно</b></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>правильно <i><span>правильно</span></i> правильно</span>." & @CRLF & _
"ошибка" & @CRLF & _
"<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>." & @CRLF & _
"ошибка" & @CRLF & _
"<span><spar>правильно</spar></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span><span></span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>ошибка<span>ошибка<span>правильно</span>" & @CRLF & _
"<span>ошибка<span>" & @CRLF & _
"Конец." & @CRLF & _
"" & @CRLF & _
"Начало." & @CRLF & _
"<spar>ошибка</spar>" & @CRLF & _
"<span><b>правильно</b></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>правильно <i><span>правильно</span></i> правильно</span>." & @CRLF & _
"ошибка" & @CRLF & _
"<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>." & @CRLF & _
"ошибка" & @CRLF & _
"<span><spar>правильно</spar></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span><span></span></span>" & @CRLF & _
"ошибка" & @CRLF & _
"<span>ошибка<span>ошибка<span>правильно</span>" & @CRLF & _
"<span>ошибка<span>" & @CRLF & _
"Конец." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")