import Foundation
let pattern = #"<span>(?:[^<]|<(?!span>|\/span>))*<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)