using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^(feature|chore|fix|security|wip)\/[A-Z0-9]+-[0-9]+[A-Za-z0-9|_|-]+$";
        string input = @"feature/NSPS2-1284_update-validation
feature/NSPS2-1277_AValidBranchName
chore/NSPS2-1277_AValidBranchName
fix/NSPS2-1277_AValidBranchName
security/NSPS2-1277_AValidBranchName
wip/NSPS2-1277_AValidBranchName";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}